Wprowadzenie do Planisty


Parametry uzupełniane w USOS:

    1. Definicja cyklów dydaktycznych (rok i semestr) - wykonuje UCTI;

    2. Definicja kalendarza roku akademickiegiego: Słowniki -> Słowniki Przedmiotów i zajęć -> Kalendarz - wykonuje corocznie UCTI na podstawie Zarządzenia rektora w sprawie organizacji roku akademickiego;

    3. Definicja Sal dydaktycznych w poszczególnych budynkach Politechniki, które będą wykorzystywane w procesie dydaktycznym Jednostki – wykonuje UCTI po przesłaniu wykazu sal.

      W skład wykazu powinny wchodzić oprócz numeru sali i ilości miejsc, także dodatkowe atrybuty, które są pomocne w trakcie tworzenia planu w Planiście np.: sala komputerowa, sala z projektorem multimedialnym, sala z projektorem multimedialnym i komputerem itp. Poniżej widoki z Słownik -> Budynki:

      Sala widok ogólny
      Sala atrybuty1

 

  1. Tworzenie Grup Przedmiotów dla wszystkich kierunków i lat dla cyklu, do którego będzie tworzony plan - wykonuje Dziekanat danej Jednostki.

okno startowe

 


Wymagane kroki do pracy w Planiście:

  1. Konfiguracja połączenia z bazą danych - wymagany kontakt z UCTI w sprawie podania adresów IP oraz utworzenia konta w systemie USOS z odpowiednimi uprawnieniami wymaganymi do poprawnego działania programu.
    Plik -> Konfiguracja -> Ogólne.

  2. Konfiguracja widoczności dni tygodnia w planiście, parametr ten może być wykorzystany w łatwiejszym planowaniu zajęć np.: dla planu studiów stacjonarnych można wyłączyć widok soboty i niedzieli i odwrotnie przy planowaniu zajęć dla studentów niestacjonarnych można włączyć widok tylko piątku, soboty i niedzieli. Plik -> Konfiguracja -> Siatki. W zależności od potrzeb można zmienić także wielkość czcionek oraz wymiary siatki.

  3. Tworzymy Nowy plan, plan ten jest wspólny dla wszystkich studentów danej Jednostki stacjonarnych i niestacjonarnych (dzięki temu widoczne jest całościowe obciążenie sal i pracowników Jednostki). Podczas tworzenia planu podajemy: Kod planu (po uzgodnieniu z UCTI kod powinien zawierać Nazwę Jednostki rok i semestr np.: WNE_2015/16_lato); krótki opis w celu łatwiejszego wyszukiwania planów; Jednostkę dla której tworzony jest plan oraz zakres dat w trakcie których plan jest wyświetlany studentom w USOSWebie




  4. Ustawienia parametrów planu (Przycisk w grupie Okna w kontekście planu roboczego lub Narzędzia -> Parametry planu):
    1. Ustawienie Jednostki Dawcy i Biorcy - wymagane jest ustawienie obu jednostek;
      Screen Shot 01 26 16 at 10.54 AM 001
    2. Ustawienie Cyklu dydaktycznego - niezbędne jest wybranie Roku Akademickiego oraz semestru, na który jest układany plan;
      Screen Shot 01 26 16 at 10.54 AM 002
    3. Wybranie odpowiednich sal dydaktycznych;
      Screen Shot 01 26 16 at 10.55 AM
    4. Wybranie Miejsca odbywania się planu;
      Screen Shot 01 26 16 at 10.55 AM 001
  5. Po wyżej wymienionych krokach w konfiguracji Planisty, powinny być widoczne już wszystkie Grupy, Przedmioty oraz sale, na podstawie których jest teraz możliwe układanie planu.

    Praca w Planiście możliwa jest w kontekście planu roboczego (widoczny tylko dla pracownika układającego plan) oraz w kontekście planu oficjalnego, który jest widoczny w systemie USOSWeb.

    Szczegóły na temat działania Planisty dostępne są w oficjalnej dokumentacji.

  6. Zapisanie planu roboczego do wersji oficjalnej wykonujemy za pomocą przycisku "Zapisz w wersji oficjalnej". Plan po zapisaniu widoczny jest na drugi dzień po opublikowaniu (jest to związane z migracją z systemu USOS do USOSWeb).

Dopasowanie ilości spotkań w celu dostosowania planu do Zarządzenia Rektora PK Nr 14/2016:

  1. W pierwszej kolejności należy rozbić istniejące terminy zajęć na spotkania. Można tego dokonać na etapie tworzenia planu, bądź też na końcu, rozbijając hurtem wszystkie terminy na spotkania według kalendarza roku akademickiego. W tym celu należy skorzystać z listy grup zajęciowych i przefiltrować przedmioty według cyklu oraz kodu jednostki.

  2. Następnie należy zaznaczyć wszystkie (CTRL + A) lub pożądane przedmioty, kliknąć prawym przyciskiem myszy i wybrać opcję "Rozbij terminy z planu" (w przypadku pracy w kontekście planu roboczego.)
  3. Kolejnym krokiem jest właściwe rozbicie terminów na spotkania. Program automatycznie utworzy odpowiednią liczbę spotkań w oparciu o terminy zajęć (co tydzień / parzyste / nieparzyste). Zaznaczenie opcji "uwzględnij kalendarz" powoduje, że dni wolne od zajęć będą pomijane przy rozbijaniu.
  4. Jeśli w danym semestrze istnieją dni, w których odbywają się zajęcia z innego dnia tygodnia, należy usunąć spotkania w danym dniu. W tym celu należy z menu "Narzędzia" -> "Operacje zbiorcze na spotkaniach" wybrać opcję "Usuń spotkania z planu" (w przypadku pracy w kontekście planu roboczego), a następnie wskazać zakres czasu (ważne są także godziny!), w którym mają zostać usunięte spotkania. Domyślna maska przedmiotów (%) powoduje usunięcie spotkań wszystkich przedmiotów z danego planu.
  5. Powyższy sposób ma zastosowanie jeśli w danym dniu w ogóle nie odbywają się zajęcia. Jesli zaś zachodzi konieczność skopiowania lub przeniesienia zajęć z jednego dnia na drugi (np. z piątku na czwartek), należy z menu "Narzędzia" -> "Operacje zbiorcze na spotkaniach" wybrać polecenie "Kopiuj (lub przenieś) spotkania z planu" (w przypadku pracy w kontekście planu roboczego), wskazać grupy zajęciowe, których ma dotyczyć kopiowanie (bądź przeniesienie) zajęć oraz określić dni źródłowy i docelowy. 
  6. Aby zmiany były widoczne w systemie USOSweb, należy zapisać plan do wersji oficjalnej.